Browser compatibility for Amplitude's product website

  • Updated

This article will help you:

Amplitude's SDKs support a much wider range of browsers. Amplitude will support browsers that match any of these requirements:

  • Any browser with more than 0.5% of the worldwide browser usage market
  • The five most-recent Firefox versions
  • The five most-recent Chrome versions
  • The two most-recent Edge versions
  • The three most recent Safari versions

However, it will not support browsers of the following types:

  • "Undead," browsers that are officially unsupported by the browser maker (e.g. IE 10)
  • IE 11
  • Op_mini all